J4_7F Item list - Tags usages - values item addition

More
3 weeks 2 days ago #5266 by gmapfp
Les problèmes de GMapFP sont corrigés.

Par contre, il y a à mon sens un bug dans le router de Joomla !
Je m'explique:
Si tu clic sur ton labo 1, il est bien redirigé au bon endroit, car j'ai créé un élément de menu => Article => Labo 1
Si tu clic sur ton labo 2, cela ne fonctionne pas. Il ne trouve rien, donc il ouvre l'article dans ta page d'accueil (et en plus, il y a un comportement bizarre avec ton com gantry). Ce qui n'est pas normal, car j'ai créé un élément de menu => liste d'article => catégorie de tes articles labos.
Il devrait donc afficher la fiche de cet élément de menu (du moins en J3, c'est comme cela que ça fonctionnait).

En espérant avoir été assez clair dans mes explications.

Please Log in or Create an account to join the conversation.

More
3 weeks 2 days ago #5267 by tramber91
Oui, je vois le problème
je vais pas creer un lien par item.
Ton truc de liste d'article par categorie aurai du marcher
tu as fait des modif ?

sinon,
Au niveau de l'adress du router
component/content/article/260-labo-2?layout=artilce&Itemid=106

layout=artilce pas layout=article ?
itemid=106 correspondant à la page d'accueil (lien menu id 106)
& ??

cela devrait être
https://biomecaniquejoomla4.en-toutes-lettres.fr/fr/component/content/article/260-labo-2?layout=article&Itemid=354

id 354 id du menu ou j'ai ma carte (lien de menu categorie gmapFP
biomecaniquejoomla4.en-toutes-lettres.fr/fr/carte/laboratoires

Donc ça marche avec ce lien
biomecaniquejoomla4.en-toutes-lettres.fr...t=article&Itemid=354
marche aussi avec le labo 1 (nouveau lien)
biomecaniquejoomla4.en-toutes-lettres.fr...t=article&Itemid=354

Peut être corrigé dans GmapFP ?
Sinon le probleme vient de Gantry (je ne vois pas ou, je connais bien gantry) faut tester avec Cassiopeia?
ou Joomla, une autre histoire ?

Please Log in or Create an account to join the conversation.

More
3 weeks 1 day ago #5268 by gmapfp
J'ai fais ces 2 corrections (bien vu le article : Dés fois je passe des heures à cause d'une connerie de ce genre).
Par contre, le 106, c'est Joomla qui me le génère !
$item->link = Route::_(ContentRoute::getArticleRoute($item->article_id, '', $item->language, 'article'), false);

Please Log in or Create an account to join the conversation.

More
3 weeks 1 day ago #5269 by gmapfp
C'est bon, j'ai trouvé d'où venait le problème.
C'est corrigé.

Please Log in or Create an account to join the conversation.

Time to create page: 0.172 seconds
Powered by Kunena Forum
FaLang translation system by Faboba